Passa al contingut principal

Codin laic a pro: javascript

Bo, anem a veure com programar en mode  pro ;) Els pros, ara gasten javascript (a mi no me mireu, jo li tinc mania). Però anem a veure com s'instal·la el node.js i un editor (també pro) anomenat atom (que no és més que una copia del sublime text ). Primer hem d'habilitar el repositori d'ubuntu:
Aplicacions->Administració de Lliurex->Lliurex Apt i marquem ubuntu. Accepten i es posarà a actualitzar els repositoris:
Ara instal·lem el node.js:

sudo apt-get install nodejs

Ara anem a la web d'atom (https://atom.io/) i amb tanta mala sort que no hi ha paquets per a linux en 32 bits. Ens diu que ens l'abaixem (https://github.com/atom/atom, podem abaixar-lo com a zip si no tenim el github, de tota manera ens el demanarà per instal·lar), i anem a instal·lar-lo:
1. abaixar
2. Descomprimir (unzip atom-master-zip)
3.cd atom-master
4.Instal·lació d'altres paquets de dependències:
sudo apt-get install build-essential git libgnome-keyring-dev fakeroot
5.executem l'ordre build dins de /script, a mi em dona el següent error:
cd script
./build
node v0.10 is required to build Atom, node 0.6.12 is installed, per tant, haurem d'actualitzar node.js:
sudo apt-get update
sudo apt-get upgrade
I després de mitja hora actualitzant, vegem que continua donant el mateix problema;
provem açò (https://rtcamp.com/tutorials/nodejs/node-js-npm-install-ubuntu/):
sudo apt-get install python-software-properties
sudo apt-add-repository ppa:chris-lea/node.js
sudo apt-get update
sudo synaptic (i marquem les actualitzacions de node.js) 
 
Ara si intentem .build no ens dona cap problema, encara que tarda una estoneta (a un i7, a un c2d del treball va ser una sort que era hora d'esmorzar); una vegada haja acabat, podem fer tres coses:
a) Instal·lar:
sudo ./grunt install 
b) Crear un paquet:
sudo ./grunt mkdeb 
c) executar des d'ahí:
cd ..
./atom.sh
 
Ara ja tenim un editor per a programar en mode pro, ara anem a provar-ho:creem amb el node un nou arxiu (prova.js):



i ara ja podrem executar el programa:

 Ala ja som pro i programem en node.js ;)

Comentaris

Entrades populars d'aquest blog

TDDs + reutilització d'objectes en Visual Studio 2012

Doncs això, mai m'he mostrat partidari de cap metodologia de programació, ni tan sols de la programació orientada a objectes... però deu ser que em faig major ;) Anem a matar en un post dos pardals d'un tir. Anem a gastar una de les bases de les metodologies àgils (en realitat no té per què, es pot emprar en qualsevol metodologia) i anem a començar a veure com fer codi "multiplataforma". Anem a gastar Visual Studio 2012. Creem una solució de Portable Class Library (en C#): Creem una nova classe, Dau: namespace RollDice {     public class Dau     {     } Sense cap mètode. Per què sense cap mètode? Ahí està la gràcia dels TDD (Test Driven Development, Desenvolupament Orientat a Test). Anirem omplint la classe segons fallen els tests. Ara anem a afegir una nova solució, què serà de test c#: Ens crearà una classe de test buida, li canviarem el namespace per a que siga el mateix que la classe dau: [TestClass]     public class testDau     {          [TestMethod

Hui he vist la por als ulls

Estic trist ,molt trist.Vinc de la manifestació del 9 d'octubre i, puc dir que he vist moltes coses, però el que no he vist és democràcia. He vist moltes banderes d'Espanya i blaveres dels increpadors, però no he vist democràcia. Les seues paraules eren "ven aquí fuera", "te voy a meter esa bandera por el coño", etc. He vist com manifestants fàcilment identificables entraven a provocar i la Policia Nacional no feia res per evitar-ho, però no he vist democràcia. He vist com un pare utilitzava al seu fill per provocar, i amb actitud agresiva (inclús anava a pegar-li manotada a un), però no he vist democràcia. He vist com es permetia una manifestació no autoritzada que podia alterar l'ordre públic. Segons la sacrosanta Constitució Espanyola, això és il·legal, però no he vist democràcia. He vist com la Policia Nacional tractava respectuosament, i inclús es coordinava amb els feixites. A nosaltres ens miraven amb cara de fàstic, però no he vist democràc

Jocs de Blizzard

No he pogut solucionar el problema amb el dragon age, hui he intentat jugar als jocs de blizzard i ara comptaré com ho he fet. Primer de tot, instal·lar wine 1.7. La versió que tinc instal·lada és la 1.7.18 i ho he fet funcionar. La versió que m'ha instal·lat per defecte és la 1.6 i amb eixa petava el Battle.Net. La putada és que abans funcionava perfectament els jocs, però des que al launcher han afegit Battle.net fa les coses molt complicades; de moment puc jugar a 11 -20 fps. (deuria de jugar al màxim possible ;)): Veurem si puc optimitzar-ho o algo 10 minuts després Després de diversos intents he aconseguit fixar l'API a OpenGL (sempre em tornava a DirectX 9, inclus posant l'D3D11). Tal i com he llegit ací: http://geebzor.com/tech/linux/wow-ubuntu-14-04-trusty/ Obric l'arxiu WTF/Config.wtf i afegisc o modifique: SET gxAPI "OpenGL" Amb això ja em trau +60 fps i tot al màxim. PS:Obric el jocs amb wine wow.exe per a no traure el launcher de Battle.net